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License Expired When Trying To Access GlobalCapture Modules After Upgrade

Problem

When trying to access a GlobalCapture module after an upgrade, you get an "License Expired" message. This message is normal, but should not persist past the standard timeout for the license. .

Cause

There are several potential causes for this, but typically it has to do with the upgrade creating a local SSAdmin and SSAdministrator on the application server, which can break authentication.

If this is not the case, it can also be an issue related to registration issue with the engine and server.

Solution

Solution 1

If you're using Domain Authentication and you've recently upgraded, it's possible that the upgrader has created a local SSAdmin and/or SSAdministrator. This can cause conflicts when the authentication process is invoked by using the local SSAdministrator/SSAdmin in place of the domain SSAdministrator/SSAdmin.

To remedy this run compmgmt.msc

Find "Users and Groups" under system tools

If SSAdministrator exists under "Users" remove it

If SSAdmin exists under "Groups" remove it

Attempt to access the GlobalCapture Module again

Solution 2

If Solution 1 is not applicable, it may be necessary to re-register the application. Re-registering will wipe out any issues related to a bad registration. This will require a Square 9 Tech to fully resolve, so filling out a support ticket in advance is advisable.

Navigate to your inetpub/wwwroot/square9captureapi/bin directory

Set the directory view permissions to "Show Hidden Files"

Locate "ssgs.ini" and move it out of that folder (to the desktop or another holding location)

From here, the GlobalCapture application will be running as unregistered. You should now have access to the application, which will be running in Demo Mode.

Attempt to log in and navigate to the Management module, and hit "Registration" on the left hand column

Both your Capture Engine and Capture Server should be running as "Unregistered"

At this point, you will need to contact Square 9 Support and request a registration reset request. Once the request has been fulfilled, you'll have to re-enter your GlobalCapture Server and Engine registration. Please note, it is advised to always register the Server before the engine.

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