The following matrix shows the compatible GlobalForms and GlobalCapture Versions.  Please also note the compatible NodeJS versions.


GlobalForms Version

Minimum Compatible GlobalCapture Version

10.1.0.0

2.1.1.0

10.2.0.0

2.1.2.0

10.2.1.0

2.2.0.0

10.2.1.102

2.3.0.0

10.2.1.102

2.4.0.0

10.3.0.0

2.3.0.0

10.3.0.0

2.4.0.0

  • Please note that there are several types of GlobalForms features that require you to be on the latest GlobalCapture and GlobalForms release update.

Compatible GlobalSearch version to GlobalCapture. 

GlobalSearch

GlobalCapture

4.5.2.101     

2.1.1.0

4.5.2.101     

2.1.2.0

4.5.2.139      

2.2.0

5.0.0.0

2.1.2.0

5.0.0.0

2.2.0

5.0.0.111     

2.2.0

5.0.0.111     

2.3.0

5.0.0.111***

2.4.0

6.1.0.0

2.3.0***

6.1.0.0

2.4.0

6.2.0.0

2.3.0***

6.2.0.0

2.4.0

  • (***) Please note while Global Capture 2.4.0 will release to older versions of Global Search there is a login method change at 6.1.0 and 2.4.0. You may have missing features if you are not on version 6.1.0.x. Users will get different login prompts between the 5.x and 2.4.x. It's suggested that you upgrade to 6.x instead.

Global Capture and it's related Compatible mongo version.

Global Capture

MongoDB

2.1.1.0

3.4.6

2.1.2.0

3.4.6

2.2.0

3.4.6

2.3.0

3.4.6

2.4.0

3.4.6, (4.2.13 on new install. Compatible up to 4.4)

  • The 2.4 installer does not upgrade mongo beyond 3.4.6. If customers would like their mongo database upgraded they must perform the upgrade themselves. Please take full server and database backups before attempting an upgrade.

  • Caution, mongo 4.4 is not compatible with Windows Server 2012. 

GlobalSearch and it’s related Windows version use span

GlobalSearch

Windows

4.5.2.101    

Windows Server 2008R2, 2012, 2016, 2019, Windows Pro, 7, 8/8.1 and 10

4.5.2.139      

Windows Server 2008R2, 2012, 2016, 2019, Windows Pro, 7, 8/8.1 and 10

5.0.0.0

Windows Server 2008R2, 2012, 2016, 2019, Windows Pro, 7, 8/8.1 and 10

5.0.0.111     

Windows Server 2008R2, 2012, 2016, 2019, Windows Pro, 7, 8/8.1 and 10

6.1.0.0

Windows Server 2012, 2016, 2019, 2022, Windows Pro, 10 and 11.

6.2.0.0

Windows Server 2012, 2016, 2019, 2022, Windows Pro, 10 and 11.

GlobalCapture and it’s related Windows version use span.

GlobalCapture

Windows

2.1.1.0

Windows Server 2008R2, 2012, 2016, 2019, Windows Pro, 7, 8/8.1 and 10

2.1.2.0

Windows Server 2008R2, 2012, 2016, 2019, Windows Pro, 7, 8/8.1 and 10

2.2.0

Windows Server 2008R2, 2012, 2016, 2019, Windows Pro, 7, 8/8.1 and 10

2.3.0

Windows Server 2012, 2016, 2019, 2022, Windows Pro 8/8.1, 10 and 11.

2.4.0

Windows Server 2012, 2016, 2019, 2022, Windows Pro, 10 and 11.


  • Installers will actively block installs on Win7 SP1 or Server2008 R2 SP1 as of GlobalSearch 6.2, GlobalCapture 2.4, and GlobalForms 10.3. Do not attempt installs on these platforms.

  • While some older legacy versions of GlobalSearch may function on newer Windows versions. Older versions are not tested on newer Windows platforms.

  • Not Recommended for new Installs, Server (2012, 2012R2, 2016). (This is the time frame this recommendation is taking place 6.1 to 6.2, 2.3 to 2.4 and all versions after this.) We don’t recommend installing older Windows versions for older software versions either. We would prefer you keep your Windows and related GlobalSearch\GlobalCapture versions with in their respective use range. Most customers will be recommended to migrate to a new Windows server as we don’t recommend in place Windows upgrades. To be clear, we DON’T recommend an in place upgrade for example from 2016 to 2022, you should migrate your GlobalSearch to a new Windows platform using our migration guide.

  • When Microsoft ends support for an operating system we also end support. These versions are historically listed. "Windows 8 and 8.1: Square 9 will be ending support for Windows 8 and 8.1 in all versions of GlobalCapture, GlobalSearch, and GlobalForms by the end of May 2022. If your devices do not utilize later versions of Windows, we recommend you update before this end date."